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WatchGuard Firebox X Core Series 

Interoperability Profile 
 

OVERVIEW  

This document describes how to configure Firebox X Core Series to implement Scenario 1 that the 

VPN Consortium specifies in “Documentation Profiles for IPSec Interoperability”, 

(http://www.vpnc.org/InteropProfiles/Interop-01.html) 

Typical VPN Configure 

Figure 1 depicts a typical gateway-to-gateway VPN topology. 

Figure1 Gateway-to-Gateway VPN Topology 

 

 Gateway A connects the internal LAN 10.5.6.0/24 to the Internet. Gateway A's LAN interface 

has the address 10.5.6.1, and its WAN (Internet) interface has the address 14.15.16.17. 

 Gateway B connects the internal LAN 172.23.9.0/24 to the Internet. Gateway B's WAN 

(Internet) interface has the address 22.23.24.25. Gateway B's LAN interface address, 

172.23.9.1, can be used for testing IPSec but is not needed for configuring Gateway A. 

The IKE Phase I parameters used in Scenario 1 are: 

�  Main mode 

�  Triple DES 

�  SHA-1 

�  MODP group 2 (1024 bits) 

�  pre-shared secret of "hr5xb84l6aa9r6" 

�  SA lifetime of 28800 seconds (8 hours) with no kbytes rekeying 

The IKE Phase 2 parameters used in Scenario 1 are: 

�  Triple DES 

�  SHA-1 

�  MODP group 2 (1024 bits) 

�  Perfect forward secrecy for rekeying 

�  SA lifetime of 3600 seconds (one hour) with no kbytes rekeying 

�  Selectors for all IP protocols, all ports, between 10.5.6.0/24 and 172.23.9.0/24, using IPv4 

subnets. 
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Install WatchGuard System Manager 

If you had installed the WatchGuard System Manager and activated the Firebox, go ahead, 

otherwise please click here to get information for how to install and activate the Firebox. 
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Basic Configuration Setup 

When finished installing the WatchGuard System Manager, you can use the WSM to configure the 

Firebox. 

Step1 Starting WatchGuard System Manager 

From the Windows Desktop, select 

Start > All Programs > WatchGuard System Manager 9.1 > WatchGuard System Manager 

WSM Main Screen appears 

Figure2 WSM Main Screen 

 
 

Step2 Connecting to a Firebox 

1. Select File > Connect to Device.  

or Click the Connect to Device icon on the WatchGuard System Manager toolbar. The icon 

is shown on the left. 

The Connect to Firebox dialog box appears. 

Figure3 Connect to Firebox dialog box 

 

2. In the Firebox drop-down list, input the IP address of Gateway A. Be sure the IP address of the 

PC is in the same subnet with the Gateway A. For example, configure your PC’s IP address as 

10.5.6.100, submask is 255.255.255.0. 

3. Input the status (read-only) passphrase. Keep the other default value and click Login.  

The Firebox appears in the WatchGuard System Manager window 

Figure4 WSM Manager window 
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Step3 Opening Policy Manager 

To bring up the Policy Manager window, from the WatchGuard System Manager window: 

Select the Firebox whose Policy Manager you want to see and select Tools > Policy Manager or 

click the Policy Manager icon on the WatchGuard System Manager toolbar (shown below). 

 

The Firebox Policy Manager appears 

Figure5 Policy Manager window 

 
 

Step4 Configure Firebox Interfaces 

1. From Policy Manager, select Network > Configuration or click the Network Configure icon on 

the WatchGuard System Manager toolbar (show below) 
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The Network Configuration dialog box appears. 

Figure6 Network Configure dialog box 

 

 Configure the External Interface 

1. In the Interface Tab, select external interface (interface 0). Click Configure. 

The external Interface Settings dialog box appears. 

Figure7 External Interface Settings dialog box 

 

2. In the General Tab, select Use Static IP, in the IP Address field, enter the IP address of the Public 

interface for Gateway A, Use slash notation to specify networks, 14.15.16.17/24. 

3. Configure the Default Gateway, set 14.15.16.1 shown above. 

4. Click OK, The Manager returns to the Network Configure dialog. 

 Configure the Internal Interface 

1. In the Interface Tab, select trusted interface (interface 1), Click Configure. 

The trusted Interface Settings dialog box appears. 
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Figure8 Trusted Interface Settings dialog box 

 
2. In the General Tab, in the IP Address field, input 10.5.6.1/24 as the IP address of the internal LAN 

interface for Gateway A, shown above. 

3. If you want to configure the Firebox as a DHCP server for trusted networks behind the Firebox, 

select the Use DHCP Server, Click Add next to the Address Pool box. 

The Add Address Range dialog box appears. 

Figure9 Add Address Range dialog box 

 

4. Specify starting and ending IP addresses on the same subnet as the trusted network, here we 

input starting IP address as 10.5.6.2 and ending IP address as 10.5.6.254. 

[Note]: Starting and Ending IP address can’t be same as the primary network and broadcast IP. 

6. Click OK. 

7. From Policy Manager, click File > Save > To Firebox, or Click the Save to Firebox icon on the 

Policy Manager toolbar, the icon is shown below, save the configuration to the Firebox. 

 
You have completed all required steps to configure the private and public interfaces for Gateway. 
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Configuring Gateways 

A gateway is a connection point for one or more tunnels. To create a tunnel, first you must set up 

gateways on both the local and remote devices.  

Step1 Defining gateway endpoints 

1. From Policy Manager, click VPN > Branch Office Gateways. 

The gateways dialog box appears 

Figure10 Gateways dialog box 

 
2. A set of gateway endpoints is known as a gateway pair. to add a gateway, click Add. 

The New Gateway dialog box appears 

Figure11 New Gateway dialog box 

 

3. In the Gateway Name text box, input a name to identify this gateway in Policy Manager for this 
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Firebox, here we use the name of VPNC-A shown above. 

4. From the New Gateway dialog box, select Use Pre-Shared Key and input shared secret for this 

VPN connection, hr5xb8416aa9r6. 

[Note]: You must use the same shared key on the remote device. The shared key must use only 

standard ASCII characters. 

5. To define the gateway endpoints, In the Gateway Endpoints section of the New Gateway dialog 

box, click Add. 
The New Gateway Endpoints Settings dialog box appears. 

Figure12 New Gateway Endpoints Settings dialog box 

 
6. Specify the location of the local gateway. Select the By IP Address radio button. Input the 

address of the External Interface, 14.15.16.17. 

7. Select the Static IP address radio button, input the IP address in the IP Address field, 

22.23.24.25. 

8. Specify the remote gateway location for tunnel authentication. Select the By IP Address radio 

button, input the IP address in the IP Address field, 22.23.24.25, the configured Gateway 

Endpoints Settings are shown below. 

Figure13 The configured Gateway Endpoints Settings screen 
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9. Click OK to close the New Gateway Endpoints Settings dialog box, return to The New 

Gateway dialog box. The Pre-Share Key and Gateway Endpoint have been configured is shown 

below. 

Figure14 The New Configured Gateway screen 

 
Step2 Configuring mode and transforms (Phase 1 settings) 

Phase 1 of establishing an IPSec connection is where the two peers make a secure, authenticated 

channel they can use to communicate. This is known as the ISAKMP Security Association (SA).  

A Phase 1 exchange can use either Main Mode or Aggressive Mode. The mode determines the type 

and number of message exchanges that take place during this phase. A transform is a set of security 

protocols and algorithms to protect data. During IKE negotiation, the peers make an agreement to 

use a certain transform.  

1. On the New Gateway dialog box, select the Phase1 Settings tab. 

The default Phase1 Settings dialog box appears. 

Figure15 New Gateway for Phase1 Settings 
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2. From the Mode drop-down list, select Main. 

3. Select the SHA1-3DES in Transform Settings column, then click Remove. 

4. Click Add for setting the VPN Consortium requirements they meet. 

The default Phase1 Transform dialog box appears. 

Figure16 Phase1 Transform dialog box 

 
5. From the Authentication drop-down list, select SHA1 as the type of authentication. 

6. From the Encryption drop-down list, select 3DES as the type of encryption. 

7. Keep the default value of SA Life, eight hours (28800 seconds). 

8. From the Key Group drop-down list, select the Diffie-Hellman group2. 

Diffie-Hellman groups determine the strength of the master key used in the key exchange process.  

All configured have been done, the Phase1 Transform is shown below. 

Figure17 The Configured Phase1 Transform screen 

 
9. Click OK, return to the New Gateway dialog box.  

The configured gateway is shown below. 

Figure18 The Configured Phase1 Setting screen 
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10. Accept default values for all other parameters of the New Gateway. Click OK on the New 

Gateway dialog box, return to the configured Gateways dialog box, shown below. 

Figure19 The configured Gateways screen 

 

11. Click Close, and now we have finished the Gateways configuring. 
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Configuring a Phase2 proposal 

Create an IKE proposal to meet the VPN Consortium requirements. 

1. To add a new proposal, from Policy Manager, select VPN > Phase2 Proposals. 

The Phase2 Proposals dialog box appears, shown below. 

Figure20 Phase2 Proposals dialog box 

 
2. Click Add to create a new phase2 proposal. 

The default New Phase2 Proposal dialog box appears 

Figure21 New Phase2 Proposal dialog box 

 
3. Input the name for the new proposal you want, here we input the VPNC_IKE . 

4. From the Type drop-down list, select ESP as the proposal method. 

5. From the Authentication drop-down list, select SHA1 as the authentication method. 

6. From the Encryption drop-down list, select 3DES as the encryption method. 

7. To make the gateway endpoints generate and exchange new keys after a quantity of time or 

amount of traffic passes. From the Force Key Expiration drop-down list, select Enable. In the 

fields below, enter one hour and 0 kilobytes. 

The new configured Phase2 proposal is shown below. 

Figure22 The new configured Phase2 Proposal screen 
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8. Click OK and return to the Phase2 Proposals dialog box. 

9. Click Close on the Phase2 Proposal dialog box and return to the Firewall Policy Manager 

dialog box. 

10. From Policy Manager, click File > Save > To Firebox, or Click the Save to Firebox icon on 

the Policy Manager toolbar, the icon is shown below, save the configuration to the Firebox. 
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Making Tunnels between Gateway Endpoints  

Step1 Configuring routes for the tunnel 

1. From Firewall Policy Manager, select VPN > Branch Office Tunnels. 

The Branch Office IPSec Tunnels dialog box appears. 

Figure23 Branch Office IPSec Tunnels dialog box 

 

2. Click Add.  

The New Tunnel dialog box appears: 

Figure24 New Tunnel dialog box 
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3. In the Tunnel Name box, set the name to tunnel.1. 

4. From the Gateway list, select the gateway for this tunnel to use, here we select the VPNC-A 

defined before. 

5. Click the Add button on the New Tunnel dialog box. 

The Tunnel Route Settings dialog box appears: 

Figure25 Tunnel Route Settings dialog box 

 

6. Click the button adjacent to the Local drop-down list to enter the local network address, here we 

enter 10.5.6.0/24. 

7. Click the button adjacent to the Remote drop-down list to enter the remote network address, here 

we enter 172.23.9.0/24. 

The configured Tunnel Route Settings are shown below. 

Figure26 The configured Tunnel Route Settings screen 

 
8. Keep the other parameters as the default value and click OK, return to the New Tunnel dialog 

box. 

Step2 Configuring Phase 2 settings 

1. From the New Tunnel dialog box, select the Phase2 Settings tab. 

Default configuration of Phase2 Settings are shown below. 

Figure27 Phase2 Settings dialog box 
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2. Set the PFS check box to enable Perfect Forward Secrecy (PFS), from the PFS drop-down list, 

select the Diffle-Hellman Group2. 

3. Click Settings to verify the Create one SA that includes all ports and protocols check box of 

the Advanced SA Settings dialog box has selected by default. 

The Advanced SA Settings dialog box appears.  

Figure28 The Advanced SA Settings dialog box 

 

4. Click OK to close the Advanced SA Settings and return to the Phase2 Settings. 

5. Select the ESP-AES-SHA1 in IPSec Proposals column, then click Remove. 
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6. Click Add button on the Phase2 Settings tab, to add the Phase2 Proposal named VPNC_IKE  

we defined in Step 4. 

New Phase2 Proposal appears: 

Figure29 New Phase2 Proposal dialog box 

 
7. Select the Use an existing Phase 2 proposal check box. 

8. From the drop-down list, select the proposal named VPNC_IKE . Click OK, return to the New 

Tunnel dialog box. 

The configured Phase2 Settings are shown below. 

Figure30 The configured Phase2 Setting screen 
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9. Click OK, the New Tunnel dialog box will closed and returns to the Branch Office IPSec 

Tunnel dialog box. 

10. Click Close button on the Branch Office IPSec Tunnel dialog box, return to the Firebox 

Policy Manager dialog box. 

11. From Policy Manager, click File > Save > To Firebox, or Click the Save to Firebox icon on 

the Policy Manager toolbar, the icon is shown below, save the configuration to the Firebox. 

 
 

All the steps have been finished for IPSec VPN creation, you will set up the tunnel between 

Gateway A and Gateway B successfully according to the all steps above. Once the tunnel is 

established, the state of the tunnel will be displayed in the WSM main screen is shown below. 

Figure31 The configured WSM main screen 
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Testing Connectivity 

 Internet Connectivity 

Ping from one PC inside the trusted network of Gateway A to the gateway of Gateway B’s external 

interface (here the gateway IP address is 22.23.24.1), and from another PC inside the trusted 

network of Gateway B to the gateway of Gateway A’s external interface (here the gateway IP 

address is 14.15.16.1), if the Ping is successful both two sides, the network is configured and 

working properly. 

 SA Connectivity 
PING from the one PC inside of the origin gateway to the one PC inside of the destination gateway to 

test whether the tunnel works well, if Ping is successful, the IPSec VPN is configured and working 

properly. 
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Troubleshooting Tips for the IPSec VPN Configuring 

A few of the most common issues found in configuring the IPSec VPN are described below. 

¨  Is the Internet working 
Testing the network status according to the Testing Internet Connectivity Step above. 

¨  Is the IP address configured correctly 
Take a note at the IP addresses and subnet masks you have configured correctly. 

¨  Is the Pre-Share Key match 
Be sure that you entered the same shared secret in the configuration of both Gateway A and 

Gateway B. 

¨  Is all the parameters for phase1 and phase2 match 
Guarantee the values for all parameters for the phase1 and phase2 setting on the local network 

match those values on the remote network exactly. 
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Appendix A: Quick Setup Wizard 

Step1 Getting feature keys 

1. Open a web browser and connect to: https://www.watchguard.com/activate 

2. If you have not already logged in to LiveSecurity, you are directed to the LiveSecurity Log In 

page. Input your LiveSecurity user name and passphrase, If you are a new user, please create a user 

profile first. 

3. Input the serial number or license key for the product as it appears on your printed certificate, 

including the hyphens. You usually use the serial number to register a new Firebox, and the license 

key to register add-on features. 

 

4. Click Continue. The Choose Product to Upgrade page appears.  

5. From the drop-down list, select the Firebox to which you want to apply the upgrade or renewal. If 

you added a Firebox name when you registered your Firebox, that name appears in this list. After 

you select the Firebox, click Activate.  

6. The Retrieve Feature Key page appears. From your Windows Start menu, open Notepad or any 

application into which you can save text. Copy the full feature key from this page to a text file and 

save it on your computer. Click Finish. 

Step2 Installing WatchGuard System Manager 

1. Download the latest strong encryption WatchGuard System Manager software from 

https://www.watchguard.com/archive/softwarecenter.asp,  

2. Execute self-extracting file, follow the screens until the “WatchGuard Firebox X Set-up: 

Set-up Complete” screen. 

Step3 Make the basic configuration for Firebox 

1. Connect the red cross-over Ethernet cable that ships with your Firebox between the Ethernet port 

on your management station and the interface 1 on your Firebox, shown below.  

 
2. Plug the power cord into the Firebox power input and into a power source. 

3. On the front of the Firebox X, press the down arrow button while you turn on the power to the 
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Firebox until display “WatchGuard Technologies” on the LCD display. The Firebox X boots into 

safe mode. While in this factory-default mode, the LCD shows the model number followed by the 

word “safe” in lower-case characters, as display below. 

 

 
4. Select Start > All Programs > WatchGuard System Manager 9.1 > Quick Setup Wizard 

The Firebox Quick Setup Wizard Welcoming screen is shown below. 

 

5. Click Next. 

6. If your Firebox have connected to your PC, powered up and in the safe mode, select the Yes, my 

firebox is ready to be discovered check box, click next, WSM will scan your Firebox. 

7. When the wizard found the firebox, it will be shown below. 

The information screen of the Firebox. 
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8. Click Next, add contact information to your Firebox. 

9. Click Next, the External interface configuration screen appears, here we select Static IP 

Addressing, shown below. 

 

10. Click Next, enter the External interface IP address you want, here we enter 14.15.16.17 VPN 

Consortium required, default gateway we set 14.15.16.1, shown below. 
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11. Click Next, Configure the Internal interface of your Firebox appears, here we set the 10.5.6.1 as 

the internal interface IP address, shown below, if you also want to configure the Optional Interface, 

enter the IP address. 

 

12. Click Next, skip the Configure the DNS information and Enable remote management steps, 

the Activate the software for Firebox dialog appears, past the feature key text in this field or click 

Browse to install the feature key from a file, shown below. 
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13. Click Next, Create the passphrases for your Firebox appears, Input the Status Passphrases and 

Configuration Passphrases in the corresponding field. 

 

14. Click Next, Confirm the configuration for your Firebox  appears, click Next continue, the 

configuration will upload to Firebox, shown below. 
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15. When the uploading finished, the completed successfully will appears, click Finish, the 

activation and basic configuration accomplished, the Firebox will auto reboot. 

 

16. After the Firebox start again, configure a static IP address of the PC connected to the Firebox 

within the same subnet, and now you can go to the Basic Configuration Setup step to begin IPSec 

VPN creation.  
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Appendix B: Firebox Parameters for IKE 

Parameters for IKE Definition VPN Consortium Required 

General Settings 

Credential method 
To identify the authentication procedure to use, you 

can use Pre-Shared or Certificate. 
Pre-Shared 

Phase 1 Settings 

Mode 

The mode determines the type and number of message 

exchanges that take place during this phase, you can 

select Main, Aggressive, or Main fallback to 

Aggressive. 

Main 

NAT Traversal 

Allows traffic to get to the correct destinations when 

the tunnel built between the Firebox and another 

device that is behind a NAT device. 

N/A 

IKE Keep-alive 
To have the Firebox send messages to its IKE peer to 

keep the VPN tunnel open. 
N/A 

Authentication The type of authentication, SHA1 or MD5. SHA1 

Encryption 
the type of encryption, AES (128-bit), AES (192-bit), 

AES (256-bit), DES, or 3DES. 
3DES 

SA Life To change the SA (security association) life 2800 seconds (8 hours) 

Key Group 

Determine the strength of the master key used in the 

key exchange process, WatchGuard supports groups 

1, 2, and 5. 

Group 2 (1024 bits) 

Phase 2 Settings 

PFS Enable Perfect Forward Secrecy Group 2 (1024 bits) 

Service Selector Create one SA that includes all ports and protocols Selected 

Proposal Type Data protection method, ESP or AH ESP 

Authentication 
The type of authentication method, SHA1, MD5 or 

None. 
SHA1 

Encryption 
The encryption method, The options are DES, 3DES, 

and AES 128, 192, or 256 bit. 
3DES 

Force Key Expiration 

To make the gateway endpoints generate and exchange 

new keys after a quantity of time or amount of traffic 

passes. 

Enable (one hour with no 

kbytes rekeying) 

 


